[Sources] Fonctionnement macro NATIXIS EE

Besoin d'aide ?

Modérateur : Patrice83200

Répondre
MVX69
Messages : 35
Enregistré le : 07 décembre 2013, 18:49
Localisation : GENAY (69)

[Sources] Fonctionnement macro NATIXIS EE

Message par MVX69 » 05 décembre 2018, 17:57

Bonjour à tous
NATEXIS ayant encore modifié, très récemment, l'ergonomie de son site, la macro NATEXIS EE ne peut plus trouver et donc rapatrier les cours des valeurs du PEE et PERCO.
Et je ne suis pas assez doué en langage HTML pour proposer une mise à jour!!!
Cordialement.
Philippe
Modifié en dernier par MVX69 le 05 décembre 2018, 18:39, modifié 1 fois.

Patrice83200
Messages : 951
Enregistré le : 18 août 2013, 15:29
Localisation : Toulon (Var 83)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Patrice83200 » 05 décembre 2018, 18:03

Bonsoir Philippe,

La mise à jour de la macro a été effectuée le 2 décembre dernier mais il faut également que tu télécharges la dernière version intermédiaire ICI pour qu’elle puisse fonctionner.

Patrice

MVX69
Messages : 35
Enregistré le : 07 décembre 2013, 18:49
Localisation : GENAY (69)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par MVX69 » 05 décembre 2018, 18:37

Bonsoir Patrice,
Merci pour la réponse... Mais vous êtes tellement réactifs en cas de problèmes que je me suis fait piéger par le fonctionnement de GESFINE lui-même. A la découverte du non-fonctionnement de la macro, ma réaction immédiate a été de m'assurer que j'avais bien la dernière mise à jour ("source de données...."): ce qui était le cas. D'où mon message pour avertir la communauté.
Je n'ai pas pensé à aller voir si une version "intermédiaire" de Gesfine corrigeait le pb.
D'où une question connexe (qui relève plutôt de "Améliorations"):
la mise à jour de ces modules "annexes" à l'application gesfine ne pourrait-elle pas être indiquée et notifiée indépendamment d 'une mise à jour "intermédiaire"de l'appli elle-même?
Cordialement;
Philippe

Patrice83200
Messages : 951
Enregistré le : 18 août 2013, 15:29
Localisation : Toulon (Var 83)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Patrice83200 » 05 décembre 2018, 18:44

Les mises à jour des sources se font automatiquement si le choix est validé dans les préférences de l'application. Donc, sans intervention, tu seras à jour.

Par contre, dans ce cas précis, lors de la mise en ligne de la dernière version officielle il y a eu une régression dans la récupération des données JSON qui a donc nécessité cette version intermédiaire pour que la source NATIXIS EE fonctionne.

D'une manière générale et si tu es assidu à GesFine, il est toujours intéressant de jeter un œil sur les publications intermédiaires. ;)

Bonne continuation avec GesFine

MVX69
Messages : 35
Enregistré le : 07 décembre 2013, 18:49
Localisation : GENAY (69)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par MVX69 » 12 décembre 2018, 18:44

Bonsoir Patrice
Après intégration de la version intermédiaire de gesfine, le fonctionnement de la macro "Natexis EE Clôture" ne semble pas permettre d'aller chercher sur le site "egepargne.com" (qui par ailleurs fonctionne a priori bien) toutes les valeurs que je cherche habituellement.
J'ai mouliné plusieurs fois la macro et fini par récupérer 4 valeurs sur les 6 que je cherche. Mais les 2 autres restent inaccessibles:
- EGE2: code 8250
- CAP2026: code 2926
J'ai fait aussi un essai avec la macro "Natexis EE cs Clôture" pour ces 2 valeurs: essai infructueux.
Pourtant, en mettant en service la possibilité de suivre le déroulement de la macro sur le site egepargne, on voit que les 2 macros "attaquent" les bonnes pages où se trouvent les valeurs. Peut-être n'attaquent-t-elles pas la bonne "ligne" dans la page html? mais cela je ne peux pas le voir n'ayant pas la possibilité de faire du "pas à pas" dans la lecture de la page.
Mais il me reste le rapatriement en manuel !!!

Jacques Leblond
Administrateur
Messages : 5366
Enregistré le : 04 janvier 2010, 20:03
Localisation : France (Haute-Loire 43)
Contact :

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Jacques Leblond » 12 décembre 2018, 19:06

Bonsoir Philippe,
Il semble que la macro aille trop vite par rapport au chargement des données (si elle finit par en récupérer au bout de la nième tentative).
Augmente le ratio des temporisations (en bas de l'onglet "Configuration") des propriétés de la source. Passe de 100 à 150% et indique nous si cela fonctionne mieux.

Si il en existe, remonte nous aussi tous les messages d'erreur d'importation concernant cette source depuis la log de GesFine (Icône "Message d'application" en bas à droite dans la barre d'état).

MVX69
Messages : 35
Enregistré le : 07 décembre 2013, 18:49
Localisation : GENAY (69)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par MVX69 » 13 décembre 2018, 10:41

BonjourJacques,
D'abord merci pour ta réponse...mais hélas après les modifs demandées, cela ne marche pas; et cette fois je n'ai rapatrié aucune des valeurs disponibles au 11/12/2018.
J'ai fait les essais suivants:
1) tempo passée à 150% au lieu de 100%
2)tempo passée à 200%
3) idem 2) mais avec visualisation du déroulement de la macro
Tous essais infructueux;
Ci-après les "logerror" correspondants
Salutations.
Philippe
logerror13122018.txt
(5.62 Kio) Téléchargé 7 fois

Jacques Leblond
Administrateur
Messages : 5366
Enregistré le : 04 janvier 2010, 20:03
Localisation : France (Haute-Loire 43)
Contact :

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Jacques Leblond » 13 décembre 2018, 19:10

Bonsoir Philippe,
Le navigateur intégré Gecko retourne une erreur systématiquement. C'est une erreur aléatoire que j'avais réussi à limiter mais visiblement chez toi elle est quasi systématique.

Le plus simple est de faire fonctionner la source sur l'autre navigateur. Donc dans l'onglet "Propriétés" de la source, change le Navigateur de Firefox (Gecko) à Internet Explorer.
Cela devrait marcher correctement.

Sinon avant le changement du site Natixis, avais-tu parfois le problème ? L'importation se faisait du premier coup à chaque fois ?

EDIT : J'ai mis à jour les sources Natixis pour qu'elles fassent toute l'usage d'Internet Explorer afin de limiter le problème.

MVX69
Messages : 35
Enregistré le : 07 décembre 2013, 18:49
Localisation : GENAY (69)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par MVX69 » 14 décembre 2018, 11:22

Bonjour Jacques,
Merci pour ta réponse...mais la manip demandée n'a réussi qu'à moitié.. et pose plus de questions qu'elle n'en a résolu!!!
En effet, et toujours avec la macro "Natexis EE Clôture":
- j'ai tout d'abord modifié le navigateur comme demandé dans ton message pour découvrir que le navigateur était déjà "internet explorer ( net emulation)" et non "firefox (gefko)",
- puis j'ai fait la manip de rapatriement des cours "egepargne" (avec gefko donc): essai infructueux, cf logerror ci-annexé,
- j'ai alors remodifié le nom du navigateur pour revenir à IE et refait la manip de rapatriement des cours...et j'ai alors récupéré la totalité des cours cherchés!!!
Pour ces 2 essais, je n'ai pas remodifié le "ratio de dépassement" qui était comme modifié à ta demande passé à 200%
Reste maintenant à comprendre ce qui se passe! Personnellement cela me dépasse.

Bon courage si tu trouves le temps de "dépatouiller" ce problème, sinon j'en resterai à faire plusieurs fois la tentative de rapatriement; sinon à défaut je reviendrai au "manuel".
Cordialement.
Philippe
logerror14122018.txt
(2.14 Kio) Téléchargé 1 fois

Patrice83200
Messages : 951
Enregistré le : 18 août 2013, 15:29
Localisation : Toulon (Var 83)

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Patrice83200 » 14 décembre 2018, 11:30

Bonjour Philippe,

La source « Natixis EE Clôture » fonctionnait précédemment avec le navigateur Gecko et occasionnait l'erreur « Impossible d'utiliser un objet COM qui a été séparé de son RCW sous-jacent ».

Jacques et moi avons fait hier des essais avec le navigateur IE et nous ne rencontrons plus du tout ce problème qui se produisait d'une manière aléatoire.

Assures-toi au démarrage que tu as bien la nouvelle source « Natixis EE Clôture » datée du 13/12/2018 et tournant avec IE pour laquelle tu ne devrais plus rencontrer cette erreur même en utilisant un ratio de 100%.

Cordialement.
Patrice

Jacques Leblond
Administrateur
Messages : 5366
Enregistré le : 04 janvier 2010, 20:03
Localisation : France (Haute-Loire 43)
Contact :

Re: [Sources] Fonctionnement macro NATIXIS EE

Message par Jacques Leblond » 14 décembre 2018, 12:01

Bonjour à tous les 2,
Pour compléter les propos de Patrice, ayant constaté que l'erreur était spécifique au navigateur Gecko et que la source fonctionnait aussi sous le navigateur IE, j'ai modifié et mis à disposition les sources sur le serveur hier soir.
La mise à jour automatique étant activée sur ta base, tu les as donc récupéré automatiquement avec la modification évoquée. Tu n'avais donc rien à faire au niveau du navigateur.

Pour le ratio des temporisations, tu peux le remettre à 100%. Ce n'est pas un paramètre géré par le serveur car propre à chacun.

Répondre